Back to Flocabulary.com

What are the tech requirements for accessing Flocabulary?

Flocabulary is 100% web-based, so you won't need to install any applications other than your standard web browser. Flocabulary is available through a Software as a Service (SaaS) model. All Flocabulary hosting is provided through Amazon Web Services (AWS).

Our application is designed to work on a variety of computers and devices, including those without the Flash plug-in (e.g. iPads and iPhones).

We support the following browsers:

  • Chrome
  • Firefox
  • IE, version 11 and above

We don't have any specific RAM or non-standard port requirements, and generally recommend a bandwidth of at least 100kbps to avoid extensive buffering.

Have more questions? Submit a request

Comments

Powered by Zendesk