What browser best supports Flocabulary?

Follow

Flocabulary.com has been optimized to work on all major browsers, including Chrome, Firefox,  Edge, and Safari. We also support Internet Explorer from version 11 and up, though to have the best experience, we recommend you use the latest version of Chrome, Safari or Firefox.

If you are having repeated issues on your current browser, we recommend that you try accessing flocabulary.com on a different browser. Be sure to update your browser to the latest version to be sure you're getting the full experience.

If you have trouble with a browser that should work with our site, please email us at support@flocabulary.com or by phone at 718.852.0105.

0 out of 0 found this helpful